
การวิเคราะห์ข้อมูลด้วยสถิติหลายตัวแปรทางชีววิทยาเบื้องต้น 
(Multivariate Analysis of Biological data)

          ผศ.ดร. บุญเสฐียร บุญสูง 

ภาควิชาสัตววิทยา คณะวิทยาศาสตร์ มหาวิทยาลัยเกษตรศาสตร์

 งานวิจัยทางชีววิทยาส่วนใหญ่มักจะมีตัวแปรหลายตัว ซึ่งตัวแปรเหล่านั้นมีความสัมพันธ์กันไม่
มากก็น้อย เทคนิคการหาความสัมพันธ์ของตัวแปรหลายตัว (multivariate analysis) นั้นมีหลายเทคนิค 
ในที่นี้จะขอกล่าวถึงเทคนิคที่นิยมใช้กันมากในทางชีววิทยา คือ

เทคนิคการจัดกลุ่ม (cluster analysis)

  เป็นเทคนิคที่ใช้ในการแบ่งหรือจัดกลุ่ม  Case (rows) หมายถึง สถาน ี พื้นที่ ฯลฯ ออก
เป็นกลุ่มย่อยโดยให้ Case (rows) ที่มีความคล้ายกันอยู่ในกลุ่มเดียวกัน โดยใช้ลักษณะหรือตัวแปรที่
คาดว่าจะทําให้ Case (rows) ต่างกัน ในทางนิเวศวิทยาส่วนมากใช้ species composition ในแต่ละ Case 
(rows) ซึ่งอาจเป็นข้อมูลความชุกชุม หรือข้อมูลพบ/ไม่พบชนิดของสิ่งมีชีวิต

เทคนิคการจัดอันดับ (ordination analysis)

  เป็นเทคนิคการจับกลุ่มหรือรวมตัวแปรที่มีความสัมพันธ์กันไว้ในกลุ่มหรือ Factor 
เดียวกัน ตัวแปรที่อยู่ใน Factor เดียวกันจะมีความสัมพันธ์กันมาก โดยความสัมพันธ์นั้นอาจจะเป็นใน
ทิศทางบวก (ไปในทางเดียวกัน)  หรือทิศทางลบ (ไปในทางตรงข้ามกัน) ก็ได้ ส่วนตัวแปรที่อยู่คนละ 
Factor จะไม่มีความสัมพนธ์กัน หรือมีความสัมพันธ์กันน้อยมาก

การวิเคราะห์ข้อมูลด้วยสถิติหลายตัวแปรทางชีววิทยาเบื้องต้นโดยใช้โปรแกรมสําเร็จรูป PC-
ORD for Windows

1. โปรแกรม PC-ORD  for Windows

 PC-ORD เป็นโปรแกรม Windows สําหรับวิเคราะห์ข้อมูลหลายตัวแปรทางนิเวศวิทยา 
โปรแกรมนี้เป็นเครื่องมือในการทดสอบ  non-parametric และนําเสนอในรูปแบบกราฟ มีการสุ่มเพื่อ
วิเคราะห์ข้อมูลทางนิเวศวิทยา นอกจากนี้ยังสามารถใช้แปลงข้อมูล และจัดการแฟ้มข้อมูลได้ 
โปรแกรม PC-ORD มีเทคนิคการจัดอันดับ และเทคนิคการจัดกลุ่มหลายวิธี เช่น  CCA, DCA, MRPP, 
perMANOVA, two-way clustering, TWINSPAN, Beals smoothing, diversity indices, species lists, 
Mantel test, various rotation methods, 3D ordination graphics, indicator species analysis, Bray-
Curtis ordination, city-block distance measures, species-area curves, tree data summaries, 
publication- quality dendrograms และ autopilot NMS โปรแกรมนี้สามารถวิเคราะห์ข้อมูลที่มีจํานวน
มากได้ถึง 32,000 rows/columns 

 ขั้นตอนหลักในการวิเคราะห์์ข้อมูลด้วยสถิติหลายตัวแปรทางชีววิทยาเบื้องต้นโดยใช้โปรแกรม
สําเร็จรูป PC-ORD มี 4 ขั้นตอน ดังนี้

1)การเตรียมข้อมูล (Prepare Your Data)
2) เปิดโปรแกรม PC-ORD และแปลงข้อมูล (Open PC-ORD and your data files)
3) วิเคราะห์ข้อมูล (Run an analysis)
4)การแสดงผลกราฟ (Explore your results graphically)
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2. การเตรียมข้อมูล (Prepare Your Data) 

ข้อมูลที่จะนําไปวิเคราะห์ด้วยสถิติหลายตัวแปรด้วยโปรแกรม นั้น จะต้องเตรียมข้อมูลใน Excel 
ก่อน และต้องจัดเก็บแฟ้มข้อมูลเป็นแบบ Lotus 1-2-3 (*.wk1) โดยเตรียมข้อมูลใน Excel (ดังภาพ) 
ดังนี้

row 1 ให้ใส่จํานวนสถานี/พื้นที ่หรือตัวแปรที่เราต้องการจัดกลุ่มหรือวิเคราะห์องค์ประกอบ
row 2 ให้ใส่จํานวนชนิดของนก หรือตัวแปรที่เราต้องนํามาใช้วิเคราะห์หรือทดสอบ
row 3 ให้ใส่ Q สําหรับข้อมูลที่เป็น quantitative (abundance) หรือ C สําหรับข้อมูลที่เป็น
 categorical (binary, 0/1, presence/absence)
row 4 ให้ใส่อักษรย่อชนิดของนก (species) (ไม่เกิน 8 ตัวอักษร) 
row 5 (column 1) ให้ใส่อักษรย่อของสถานีหรือพื้นที่ (samples) (ไม่เกิน 8 ตัวอักษร) 

ตัวอย่าง ข้อมูลสํารวจชนิดของนก 10  ชนิดในบริเวนพื้นที่ที่แตกต่างกัน 5 แบบใหญ่ 10 แบบ
ย่อย ซึ่งข้อมูลอาจเป็นข้อมูลความชุกชุมของนก (abundance data) หรืออาจเป็นข้อมูลพบ/ไม่พบ 
(presence/absence data)  ถ้าพบนกชนิดนั้นให้กรอกเป็น 1 ถ้าไม่พบนกชนิดนั้นให้กรอกเป็น 0

ข้อมูล abundance

ข้อมูล presence/absence (binary, 0/1)
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เนื่องจาก Microsoft Office Excel 2007 ไม่มีในส่วนการจัดเก็บแฟ้มเป็นแบบ *.wk1 จึงต้อง
บันทึกแฟ้มเป็น *.text ก่อน ซึ่งแฟ้มที่จัดเก็บนี้ไม่ได้เป็นแบบปกต ิดังนั้นเมื่อ Excel ถามให้ตอบ ตกลง 
และ ใช่ ดังภาพ

จากนั้นให้เปิดโปรแกรม Notepad เพื่อเปิดแฟ้ม *.text แล้วไปที่ File คําสั่งย่อย Save as ให้
เลือก Save as type เป็น All Files และให้พิมพ์ชื่อไฟล์ใหม่แล้วตามด้วย .wk1   ดังภาพ

เอกสารประกอบการสอนวิชา 01424491/01423491 ระเบียบวิธีวิจัยทางชีววิทยา/สัตววิทยา	

 	



PAGE 3 OF 26	

 	





2. เปิดโปรแกรม PC-ORD และแปลงข้อมูล (Open PC-ORD and your data files)

เมื่อเปิดโปรแกรม PC-ORD for Windows ขึ้นมา ไปที่คําสั่ง File > Open คําสั่งย่อย Main 
Matrix
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ทําการเปลี่ยนไฟล์ที่เปิดให้เป็น wk1 file format อีกครั้ง โดยเลือก Yes ในการแปลงไฟล์ และ
เลือก file format เป็น   Excel Spreadsheet แล้วกด  OK

เมื่อเปิดไฟล์ได้แล้วโปรแกรมจะทําการบันทึกไฟล์อัตโนมัติเป็น  TEMP.WK1 กด OK เพื่อใช้
ไฟล์นี้เป็น Main Matrix จากนั้นบันทึกไฟล์และตั้งชื่อใหม่ ดังภาพ

หากมี Error เกิดขึ้นในช่วงที่เปิดไฟล์ ให้กลับไปตรวจสอบการกรอกข้อมูลใน Excel 
Spreadsheet อีกครั้งว่ามีความผิดพลาดหรือไม่
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เนื่องจากข้อมูลเป็น abundance data  จําเป็นต้องแปลงข้อมูล (transformation) ก่อนนําไป
วิเคราะห์ ถ้าข้อมูลเป็น presence/absence data   สามารถนําไปวิเคราะห์ข้อมูลได้เลย การแปลงข้อมูล
ทําได้โดยไปที่คําสั่ง Modify Data > Relativizations > Main Matrix > General Relativization   เมื่อขึ้น
หน้าต่าง Main Matrix General Relativization ใส่คําสั่ง p  =1  แล้วกด OK  แล้วทําการบันทึกไฟล์ใหม่ 
ดังภาพ
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3.  วิเคราะห์ข้อมูล (Run an analysis)

3.1 การจัดกลุ่ม (cluster analysis)
 ดังที่กล่าวไปแล้วข้างต้นว่า หลักของเทคนิคการจัดกลุ่มจะใช้ในการแบ่งกลุ่ม Case (rows) ออก
เป็น กลุ่มย่อยโดยให้ Case (rows) ที่มีความคล้ายกันอยู่ในกลุ่มเดียวกัน ซึ่งวัดด้วยระยะห่าง (distance 
หรือ dissimilarity  measure) หรือความคล้ายกัน (similarity  measure) เทคนิคการจัดกลุ่มแบ่งเป็น
หลายเทคนิคย่อย เทคนิคที่นิยมใช้กันมากคือ Hierarchical Cluster Analysis ซึ่งเป็นเทคนิคที่ใช้แบ่ง
กลุ่ม Case (rows) หรือแบ่งกลุ่มตัวแปรโดยมีเงื่อนไขดังนี้ 

จํานวน Case (rows) ควรต่ํากว่า 200 และจํานวนตัวแปรต้องไม่มากเช่นกัน

ไม่จําเป็นต้องทราบจํานวนกลุ่มมาก่อน

ไม่จําเป็นต้องทราบว่าตัวแปรใดหรือ Case (rows) ใดอยู่กลุ่มใดก่อน

 กรณีที่วัดความคล้ายด้วยระยะห่าง ถ้าระยะห่างระหว่าง Case  (rows) คู่ใดต่ํา แสดงว่า Case 
(rows) นั้นอยู่ใกล้กันหรือมีความคล้ายกันควรจะจัดอยู่ในกลุ่มหรือ cluster เดียวกัน สําหรับวิธีคํานวน 
distance measure นั้นมีหลายวิธีขึ้นอยู่กับชนิดของข้อมูล เช่น ถ้าเป็นข้อมูล binary (0/1) นิยมวัดด้วย 
Jaccard distance เป็นต้น

 ส่วนหลักเกณฑ์ในการรวมกลุ่ม (group linkage method)  นั้นมีหลายวิธี วิธีที่นิยมใช้ใน
โปรแกรม PC-ORD คือ Group Average ซึ่งวิธีนี้จะคํานวนหาระยะห่างเฉลี่ยของทุกคู่ของ Case (rows) 
โดยที ่Case (rows) หนึ่งอยู่ใน Cluster ที่ i   ส่วนอีก Case (rows) หนึ่งอยู่ใน Cluster ที่ j, i ≠ j

 ถ้า Cluster ที่ i มีระยะห่างเฉลี่ยจาก Cluster ที่ j สั้นกว่าระยะห่างจาก Cluster อื่น จะนํา       
Cluster ที่ i และ j มารวมเป็น Cluster เดียวกัน
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 การวิเคราะห์การจัดกลุ่มในโปรแกรม PC-ORD ทําได้โดยไปที่คําสั่ง Groups > Cluster 
Analysis เมื่อขึ้นหน้าต่าง Cluster Setup ในส่วน Distance Measure ให้เลือกเป็น Sørensen (Bray-
Curtis)  เป็นวิธีที่นิยมใช้กันมากในทางนิเวศวิทยาสําหรับข้อมูล abundance  ส่วนข้อมูล binary ให้เลือก 
Jaccard และ Group Linkage Method ให้เลือก Group Average แล้วเลือกลักษณะของ Dendrogram ดัง
ภาพ
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สําหรับโปรแกรม PC-ORD version 5.10 นั้นสามารถวิเคราะห์การจัดกลุ่มแบบสองทาง (Two-
way Cluster Analysis) ได ้โดยจัดกลุ่ม rows และ columns ไว้ในเมทริกเดียว (single matrix) ดังนี ้
 ไปที่คําสั่ง Groups > Cluster Analysis เมื่อขึ้นหน้าต่าง Two-way Cluster Setup ในส่วน 
Distance Measure ให้เลือกเป็น Sørensen (Bray-Curtis)  สําหรับข้อมูล abundance  ส่วนข้อมูล binary 
ให้เลือก Jaccard และ Group Linkage Method ให้เลือก Group Average ดังภาพ

3.2 การจัดอันดับ (ordination analysis)
   การวิเคราะห์การจัดอันดับในโปรแกรม PC-ORD มีหลายวิธี เช่น Bray-Curtis, CCA, 
DCA, NMS, NMS Scores, PCA, RA และ Weighted Averaging (ดังภาพ) ในที่นี้จะขอกล่าวถึงวิธีที่
นิยมใช้กันมากในทางนิเวศวิทยา คือ Principal Components Analysis (PCA), Non-metric 
Multidimensional Scaling (NMS) และ Canonical Correspondence Analysis (CCA)
  Principal Components Analysis (PCA) เป็นวิธีการสกัดปัจจัยของการวิเคราะห์องค์
ประกอบ (factor analysis) ที่ได้รับความนิยมมาก ซึ่งมีวัตถุประสงค์ที่จะนํารายละเอียดของตัวแปรที่มี
จํานวนตัวแปรมาก  ๆ มาไว้ในปัจจัยที่มีเพียงไม่กี่ปัจจัย โดยพิจารณาจากรายละเอียดทั้งหมดจากแต่ละ
ตัวแปร วิธีนี้อาศัยหลักความสัมพันธ์เชิงเส้นระหว่างตัวแปรที่ใช้เป็นข้อมูลองค์ประกอบหลักตัวแปรคือ 
การผสมเชิงเส้นตรง (linear combination) การวิเคราะห์ PCA ทําได้โดย ไปที่คําสั่ง Ordination > PCA 
เมื่อขึ้นหน้าต่าง Principal Components Analysis เลือก Correlation สําหรับ Cross-product Matrix และ 
เลือก distance-based biplot สําหรับ Calculate Scores For Species แล้วกด OK 
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  Non-metric Multidimensional Scaling (NMS) หรือ MDS เป็นเทคนิคที่ใช้แสดงตําแหน่ง
ข้อมูลที่ใช้เป็น dissimilarity data หรือข้อมูลที่แสดงความแตกต่าง/ความคล้าย  การวิเคราะห์ PCA 
ทําได้โดย ไปที่คําสั่ง Ordination > NMS เมื่อขึ้นหน้าต่าง NMS Setup หน้าต่างย่อย Autopilot เลือก 
Autopilot mode และ Medium สําหรับ Speed vs Thoroughness หน้าต่างย่อย Distance Measure เลือก 
Sørensen (Bray-Curtis) แล้วกด OK
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 Canonical Correspondence Analysis (CCA) เป็นเทคนิคการหาความสัมพันธ์ระหว่างเมทริกของ 
species data (samples-by-species) และเมทริกของข้อมูลสิ่งแวดล้อม (environmental data) 
 การวิเคราะห์ CCA ทําได้โดย การเตรียมข้อมูลสิ่งแวดล้อม ซึ่งเตรียมเหมือนกับ Main matrix เพื่อเป็น 
Second matrix  (ดังภาพ) ทําการเปิดไฟล์ species data เป็น Main matrix และเปิด environmental data 
เป็น Second matrix จากนั้้นไปที่คําสั่ง Ordination > CCA เมื่อขึ้นหน้าต่าง CCA Setup เลือก Centering 
and normalizing, Optimize rows: sites และ sites scores are derived from species แล้วกด OK
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4.  การแสดงผลกราฟ (Explore your results graphically)
4.1 การจัดกลุ่ม (cluster analysis)
การแสดงผลกราฟหรือเดนโดรแกรม (dendrogram) ของการจัดกลุ่มนั้นทําได้โดย ไปที่คําสั่ง 

Graph > Cluster Dendrogram หรือ Two-way  Cluster Dendrogram สําหรับการวิเคราะห์การจัดกลุ่ม
แบบ Two-way Cluster Analysis  ซึ่งจะขึ้นหน้าต่าง Cluster Analysis Dendrogram หากต้องการบันทึก 
dendrogram ไปที ่File > Save Graph As ดังภาพ 
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จาก Cluster Analysis Dendrogram เมื่อพิจารณาความห่างหรือความคล้ายกันของ 10 samples 
พบว่าแบ่งออกเป็น 4 กลุ่มที่ความห่างหรือความคล้าย 50% ดังนี้

 กลุ่มที่ 1 ได้แก่ Forest1 และ Forest2 มีความห่าง 0% (หรือคล้ายกัน 90%) 
 กลุ่มที่ 2   แบ่งเป็น 2 กลุ่มย่อย ได้แก่ Planta1, Planta2 และ Wetland1, Wetland2, Wetland3 

โดยกลุ่มที่  2 มีความห่างจากกลุ่มที่ 1 ที่ 50% 
 กลุ่มที่ 3 ได้แก ่City1 และ City2 โดยกลุ่มที ่  3 มีความห่างจากกลุ่มที่ 1 และ 2 ที่  75% (หรือ

คล้ายกัน 25%)
 กลุ่มที่ 4 ได้แก่ Seashore โดยกลุ่มที่  4 มีความห่างจากกลุ่มอื่นที่  100% (หรือคล้ายกัน 0%)

จาก Cluster Analysis Two-way Dendrogram ซึ่งแสดงเดนโดรแกรมทั้ง rows (sites) และ 
columns (species) เมื่อพิจารณาความห่างหรือความคล้ายกันของ 10 sites พบว่ามีการจัดกลุ่มเหมือน
กับ Cluster Analysis Dendrogram ทุกประการ ส่วนความห่างหรือความคล้ายกันของ 10 species พบว่า
แบ่งออกเป็น 4 กลุ่มโดยที่ กลุ่มที ่ 1 (Forest1 และ Forest2) มีความสัมพันธ์กับนกชนิด spA, spB, และ 
spC ซึ่งความเข้มของสีแสดงให้เห็นถึงความชุกชุมของนกชนิดนั้นในพื้นที่นั้น

กลุ่มที ่ 2 (Planta1, Planta2 และ Wetland1, Wetland2, Wetland3) มีความสัมพันธ์กับนกชนิด  
spD  และ spE กลุ่มที่ 3 (City1 และ City2) มีความสัมพันธ์กับนกชนิด spF  และ spG และกลุ่มที ่ 4 
(Seashore) มีความสัมพันธ์กับนกชนิด spH, spI  และ spJ

เอกสารประกอบการสอนวิชา 01424491/01423491 ระเบียบวิธีวิจัยทางชีววิทยา/สัตววิทยา	

 	



PAGE 19 OF 26	

 	





4.2 การจัดอันดับ (ordination analysis) 
การแสดงผลกราฟของการจัดอันดับนั้นทําได้โดย ไปที่คําสั่ง Graph > Graph Ordination > 2D 

ซึ่งจะขึ้นหน้าต่าง Graph Ordination 2D และกด  Simple scatterplot เพื่อแสดงกราฟ หากต้องการบันทึก
กราฟ ไปที ่File > Save Graph As ดังภาพ

หากต้องการแก้ไขกราฟ
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กราฟ PCA

สําหรับกราฟ NMS ไปที่คําสั่ง Graph > Graph Ordination > 2D ซึ่งจะขึ้นหน้าต่าง Graph 
Ordination 2D และกด  Simple scatterplot เพื่อแสดงกราฟ หากต้องการบันทึกกราฟ ไปที่ File > Save 
Graph As ดังภาพ 
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กราฟ NMS

สําหรับกราฟ CCA ไปที่คําสั่ง Graph > Graph Ordination > 2D ซึ่งจะขึ้นหน้าต่าง Graph 
Ordination 2D และกด Simple scatterplot และ Joint plot (biplot) เพื่อแสดงกราฟ หากต้องการบันทึก
กราฟ ไปที ่File > Save Graph As ดังภาพ
 หากต้องการหมุนแกนหรือหมุนกราฟ  สามารถทําได้โดย ไปที ่Rotate > By Angle Continuous  
เลือก 5° for the increment และคลิก Next เพื่อหมุนแกนไปเรื่อยๆ ดังภาพ
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หากต้องการแก้ไขกราฟ  สามารถไปคลิก Preferences  และหน้าต่างย่อย Format > Styles > Fonts  ได ้
ดังภาพ
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